Search
 
 

Display results as :
 


Rechercher Advanced Search

Keywords

server  sealed  xone  application  client  

Latest topics
» Setting up a Server on Armagetron.
Mon Apr 18, 2016 7:11 pm by -=xone|Antipro

» Halo 5 - Whats the Perfect Sensitivity
Thu Mar 24, 2016 10:50 am by Xone|Spirit

» Halo 5 Forum Content Transfer...in progress
Thu Mar 24, 2016 10:39 am by Xone-Meinto

» Halo 5 - Thoughts on Riptide...
Thu Mar 24, 2016 10:22 am by Admin

» XONE SERVER LEADERBOARD!!!
Mon Jan 19, 2015 8:31 pm by TACI|FUCK YOU XONE SHIT

» Been sick hope to be back on tron this week
Wed Jan 14, 2015 4:34 pm by The Stig

» WHERE ARE WE!!!???!
Fri Jan 09, 2015 7:00 pm by -=Xone-UltrA

» Polo application
Wed Dec 24, 2014 8:00 am by -=Xone.Ray

» A small tourney
Wed Dec 24, 2014 7:58 am by -=Xone.Ray

June 2017
MonTueWedThuFriSatSun
   1234
567891011
12131415161718
19202122232425
2627282930  

Calendar Calendar

Affiliates

free forum

Forumotion on Facebook Forumotion on Twitter Forumotion on YouTube Forumotion on Google+


Troubleshooting/ Making Arma Run Smooth

View previous topic View next topic Go down

Troubleshooting/ Making Arma Run Smooth

Post by Xone|Spirit on Mon Nov 03, 2014 11:37 am

Your Game Client


"Armagetron Advanced takes most or all the CPU time, how come?"

AA takes all the CPU time it needs to simulate and render the scene as fast as you'll allow it to. There are two conditions under which that makes it take almost everything that is available:

    1. You set your graphics card driver not to wait for VSync. AA will then run at the highest possible framerate and therefore also use all the CPU time available. If you enable the FPS display in the HUD options and it shows more than 100 FPS, then that's your problem.
    2. When it tells your video card driver to update the screen now, the driver goes into a special CPU-hogging mode until the command is completed, even though all it does is sit around and wait. Both NVidia and ATI drivers are guilty of this. In the "Performance Tweaks" submenu of the graphics settings, there is the "Flush" menu item where you can tweak AA to not issue the problematic command (with possible side effects). 

"I can't seem to get into any internet games, what's wrong?"

This happens when some part of the network between you and the servers is blocking our network traffic. The guilty party can be your network provider (z-man, for example, can't play over his University WLAN) or an overzealous firewall or router. The list of products used in home networks that we know to be potentially problematic is short:

    - Norton. Both "Norton Internet Security" and "Norton 360" have a built in firewall that is active by default, and that firewall is not operating 100% correctly; see here for details and a fix: http://wiki.armagetronad.org/index.php/Norton_Firewall. Note that Norton comes pre-installed on some machines, so you may have it and not even know about it. 

The Armagetron developers don't know of any routers or other network infrastructure hardware that interferes with Armagetron Advanced in any way, and the built in firewalls of Windows Vista and Windows XP are unproblematic as well.

"Armagetron Advanced is unplayable on my AMD Dual Core X2 System."

Symptoms:

   -  The console displays "Timer hickup"
   -  FPS are usually ok (above 30).
   -  Might only occur in network games
   -  Game performance is very bad 

At least three solutions for this problem are available:

    To fix this problem use your TaskManager to set ArmagetronAd.exe's cpu affinity to a single CPU.
    - Disable Cool & Quite in BIOS
    - Install the necessary Microsoft Hotfixes and depending on your System you might have to update your BIOS and drivers too.
    - Install a 0.2.8.3 alpha client. 

Links:

    Microsoft Knowledge base Article about Q896256 (http://support.microsoft.com/default.aspx?scid=KB;en-us;896256
    AMD Dual Core Optimizer (http://www.amd.com/en-us/Processors/TechnicalResources/0,,30_182_871_13118,00.html) The fix is similiar to Microsofts, but only fixes a small part of it. The Microsoft patch also addresses power saving bugs (in Windows XP). 

Details: 

    Armagetron Advanced 0.2.8.x or later uses the high precision timer on Windows if available. This can be a problem on the new Dual Core Systems or malfunctioning Multiprocessor System. The Timer of each core runs at different speeds which results in a jumping timer! The AMD X2 Systems are affected because they have two separate timers for each CPU (Intels Core Duo CPUs share a single timer). The AMD X2 Systems are only affected with Cool & Quite power saving enabled otherwise both cores have the same timer speed. The Windows kernel schedules Armagetron Advanced between both cores which results in a jumping timer form Armagetron perspective. 

"Armagetron Advanced keeps minimizing when on fullscreen mode on Ubuntu/GNOME."

It turns out gnome-screensaver is faulty and kicks in all the time when in fullscreen. The simpliest solution is to just turn off gnome-screensaver on the control panel.  This problem only applies to the older Ubuntu releases, since GNOME screensaver was removed in the newer version.
avatar
Xone|Spirit
Forum VIP
Forum  VIP

Posts : 50
Points : 81
Reputation : 2
Join date : 2014-10-02

View user profile

Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum